MovableType(MT)3.0のインストールをしてみる

こちらこちらを見ながらMTをせっせとインストール中。


さて、インストールしているわけですが、早速エラーがガシガシ出てスムーズにいきません。
1.手始めにダウンロード後の解凍につまづく。
Lhaplusで解凍できない。仕方なくミラノさんの指示通りLhacaデラックス版をダウンロード。
いつのまにかRARまで解凍できるようになってやがる。
2.mt-test.cgiでつまづく。
http://rebecca.ac/milano/install/archives/000035.html
やってみるがページにはなにも表示されない。
HTMLのソースを除くと、「 <pre> 」としか書いてない。というか、HTMLタグじゃん!
コメント寄稿させてもらいましたが、41行目と42行目にCGIらしからぬ改行発見。
セコセコとCGIを書き直す。
3.ログイン画面でつまづく。

ぉぃ。
「Use of uninitialized value at lib/MT.pm line 869.」
って何?なぜ連打?_| ̄|○
milanoさんがいろいろ試してくれた(?)ようで、UTF-8にすることで解決。

これはおそらくMTの問題ではなく、Jcode.pmの問題なので、解決するのは難しいです。

アリガトウゴザイマス!
一族全員より御礼申し上げます。
追記:
その後はほとんどエラーないですね。
ただ、たまーにリビルドしたときに、
「Prototype mismatch: sub Params::Validate::validate_pos vs (¥@@) at extlib/Params/ValidatePP.pm line 139.
Prototype mismatch: sub Params::Validate::validate vs (¥@$) at extlib/Params/ValidatePP.pm line 370.」
という表示がでますね。
動いているから良しとしましょうか。

機械忍者

某SEO会社(?)勤務。 多分日本語よりHTMLの方が得意です。 最近はRubyとかいうキラキラな言語も勉強中です。 SEOはもう標準スキルになってきてると思うので正直もうあんまり昔ほどの熱意は感じません。 新たに躍動してる人も多いですしね。 だれか強化骨格コスプレあったら教えてください。

あわせて読みたい

3件のフィードバック

  1. aeons より:

    ミラノさんとこから来ました。
    設置おめでとうです!
    なんか、日本語版では、mt-cgiを実行したとたん、サーバーエラーになるんですよね。
    英語版は、設置できたんですが、euc-jpで文字わけ。
    mt2.661は、動いてたんですが…
    3.0は設置できないのは、どういうこと?って感じです。
    あぁ、疲れました。

  2. aeons より:

    もうアフォかとヴァカかと…

    最低最悪です。
    メインサイトのmovabletype2.661が吹っ飛びました!
    愚痴るとこが無いので、愚痴らせてください。
    頭冷やして、3.0に移行します。

    3.0の日本語版が昨日出た様で、早速テストサイトをmilanoさんのココを参考にしてやってたわけなんです。
    が、何故

  3. cyborg_ninja より:

    > mt2.661は、動いてたんですが…
    ・゚・(ノД`)・゚・
    多分ですね、EUCに原因が。
    ミラノさんのところに書いてあるとおり、変なエラーが出て、MTのせいじゃない、Jcode.pmのせいでバグってました。
    それのせいじゃないでしょうかね。

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です

このサイトはスパムを低減するために Akismet を使っています。コメントデータの処理方法の詳細はこちらをご覧ください